Dependency Installation failing for Node v14
Incident Report for Gatsby Cloud
Resolved
We have successfully resolved the issue.
Posted Mar 10, 2021 - 09:55 PST
Monitoring
We have identified the issue and have rolled out a fix. We will continue to monitor the situation.
Posted Mar 10, 2021 - 08:28 PST
Identified
We have identified the failures for customer sites using yarn to install depdencies with Node version 13.x - 14.15.x. Upgrading to Node 14.16 or using Node 12.20.1 can mitigate this. You can add a NODE_VERSION environment variable, more info here: https://support.gatsbyjs.com/hc/en-us/articles/360052322954-Environment-Variables-Specific-to-Gatsby-Cloud
Posted Mar 10, 2021 - 07:45 PST
Investigating
Many customer sites running Node v14.x are failing to install dependencies. We are investigating this issue.
Posted Mar 10, 2021 - 06:37 PST
This incident affected: Gatsby Cloud Instances.