Users are not able to build their sites due to installation error with gatsby-plugin-gatsby-cloud
Incident Report for Gatsby Cloud
Postmortem

Summary

On July 20th, 2022 at 6:40 AM ET, Gatsby was made aware of an internal change that impacted our open-source customers with any sites with a custom npmrc file. This resulted in a few customers unable to build or preview their site on Gatsby Cloud while Gatsby Engineering resolved the issue.

The issues was resolved with a code fix in 5 hours and 32 minutes.

Services Impacted

gatsby-plugin-gatsby-cloud

Timeline of Events

Identified: 6:40 AM ET

Resolved: 11:12 AM ET

Details

We made a switch from using npm to yarn for installing dependencies. In certain situations, this meant that customers were unable to build or preview their site on Gatsby Cloud.

Resolved

The issue was resolved by rolling back the change and deploying the fix for testing on a single site and then releasing it fully after passing the testing phase.

Monitoring

Gatsby’s Engineering Team identified areas in the codebase where they could apply better monitoring. They will implement additional monitoring and improve the process with incremental rollouts so future instances will not occur.

Identified

The root cause was the result of working with an older area of the codebase and not appropriately accounting for the switch from npm to yarn. Making adjustments to monitoring and testing should prevent this issue in the future.

Posted Jul 27, 2022 - 06:33 PDT

Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 09:02 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2022 - 07:19 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 20, 2022 - 06:16 PDT
Update
We are continuing to investigate this issue.
Posted Jul 20, 2022 - 03:48 PDT
Investigating
We are currently investigating this issue.
Posted Jul 20, 2022 - 03:47 PDT
This incident affected: API.