Intermittent Build Failures related to Image CDN.
Incident Report for Gatsby Cloud
Resolved
This incident has been resolved.
Posted Mar 30, 2022 - 12:03 PDT
Identified
We have identified an issue where users who are leveraging the Gatsby Cloud Image CDN resolvers in their GraphQL queries but have not enabled the Image CDN via their dashboard are encountering build errors with this message:

Error: ENOENT: no such file or directory, mkdir '/workspace/.cache/caches/gatsby'

We are pushing a fix, but in the meantime, enabling the Image CDN in Site Settings -> Image CDN should resolve the issue.
Posted Mar 30, 2022 - 09:43 PDT
Investigating
We are currently investigating this issue.
Posted Mar 30, 2022 - 08:35 PDT