Gatsby Cloud dashboard failing to load due to authentication issues.
Incident Report for Gatsby Cloud
Postmortem

Summary

On Friday, January 20th at 1:27 PM ET, Gatsby Engineering determined that the authentication service was unresponsive. Several customers also reported errors accessing the dashboard at this time.

This resulted in customers not being able to consistently access the Gatsby Cloud Dashboard over a period of 1 hour.

Services Impacted

Gatsby Cloud Dashboard

Timeline of Events

Identified: 2023-01-20 1:27 PM ET

Resolved: 2023-01-20 2:35 PM ET

Details

Gatsby Engineering released a bug that put too much strain on our database causing our APIs to become unresponsive.

Posted Jan 20, 2023 - 12:34 PST

Resolved
This incident has been resolved.
Posted Jan 20, 2023 - 12:16 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2023 - 11:36 PST
Identified
We believe the issue has been identified and are implementing a fix.
Posted Jan 20, 2023 - 11:28 PST
Investigating
The dashboard is failing to load again. The team continues to investigate.
Posted Jan 20, 2023 - 11:19 PST
Update
We are continuing to monitor for any further issues.
Posted Jan 20, 2023 - 11:07 PST
Monitoring
Dashboard is loading again. We continue to monitor.
Posted Jan 20, 2023 - 10:51 PST
Investigating
We are currently investigating this issue.
Posted Jan 20, 2023 - 10:36 PST
This incident affected: Dashboard.