Potential Build Delays
Incident Report for Gatsby Cloud
Resolved
We have upgrade our infrastructure to compute optimized machines. Build delays should be resolved. if you are having any issue, please do not hesitate to reach support@gatsbyjs.com
Posted Nov 21, 2020 - 09:13 PST
Update
The Gatsby Cloud team had a working session with on call engineers from Google Kubernetes Engine. The Gatsby Cloud infrastructure is causing unusual disk pressure causing customer builds to be delayed. We were recommended to change our machine types. We have done that and are monitoring.

We are noticing customer build durations increasing due to these new machine types. The Google team is in close communication as we figure out how to provide compute optimized workloads to our customers while keeping disk throughput down.
Posted Nov 18, 2020 - 11:36 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2020 - 10:44 PST
Identified
We have identified a fix and will be rolling it out today, this may cause short delays in starting previews or builds while we upgrade infrastructure.
Posted Nov 17, 2020 - 08:30 PST
Update
We believe we have identified a root cause for the delays, and plan to have an initial fix applied soon
Posted Nov 16, 2020 - 08:58 PST
Update
Gatsby Cloud has been in close communication with Google Cloud. Small percentages of customers may experience queued builds up to 10 minutes. We are monitoring the issue and hope to have resolution with Google Cloud.
Posted Nov 12, 2020 - 07:09 PST
Monitoring
We are in communication with Google Cloud and GKE Product Support to address random build delays.
Posted Nov 09, 2020 - 08:56 PST
Investigating
We are investigating an intermittent issue that may cause build delays
Posted Nov 05, 2020 - 09:04 PST
This incident affected: Gatsby Cloud Instances.