The Gatsby Cloud Dashboard is either slow to load or fails to load
Incident Report for Gatsby Cloud
Postmortem

Summary

On August 24th, 2022 at 2:06 PM ET, Gatsby Support was made aware that users were having issues logging into the Gatsby Cloud Dashboard. This resulted in customers not being able to access the Dashboard.

The issues was resolved with a code fix in 5 hours and 55 minutes.

Services Impacted

Gatsby Cloud Dashboard

Timeline of Events

Identified: 2022-08-24 2:06 PM ET

Resolved: 2022-08-24 8:01 PM ET

Details

Gatsby Engineering released released a change to underlying infrastructure that had not been optimized. The change resulted in latency in Gatsby Cloud. Engineering rolled back to a functional version that fixed the issue for users..

Resolved

The root cause was an unoptimized change in the underlying infrastructure.

Monitoring

Engineering rolled back to a previously working version and that fixed the issue. Engineering improved their alert system to catch Gatsby Cloud Dashboard performance decline earlier.

Identified

Engineering identified an issue with a change, refactored it and released a more performant and safer version of it. The service is now more sensitive toward latency in Gatsby Cloud.

Posted Sep 02, 2022 - 06:08 PDT

Resolved
We are seeing normal activity using the dashboard. The incident has been resolved.
Posted Aug 24, 2022 - 17:01 PDT
Monitoring
We have mitigated the issue. We will continue to monitor.
Posted Aug 24, 2022 - 13:43 PDT
Update
We are continuing to investigate the issue.
Posted Aug 24, 2022 - 13:19 PDT
Investigating
We have received reports that the dashboard won't load for some users. We are currently investigating the issue.
Posted Aug 24, 2022 - 11:06 PDT
This incident affected: Dashboard.